Benchmark publication delays

Incident Report for Vinter Services

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 16:26 UTC

Investigating

We are currently seeing delays in the publication of Benchmarks. We are working on it and will update the page when the issue has been resolved.
Posted Apr 09, 2025 - 15:40 UTC
This incident affected: Index dissemination.